Electrophysiological recording of the
trigeminofacial reflex during NNS in human

preterm infants: NeoFlex RT

R Vantipalli, J Wang & S.M. Barlow

CNL Technical Research Report, 2006, 2:1-19.

University of Kansas

Lawrence, Kansas USA

Reprint available at www.ku.edu/~cnl



NeoFlex RT CNL U of Kansas

Table of contents

1 NEOFIEX RT SEUUD ...eeitieiiiie ettt ettt sbe e b b 3
L1 HAIAWAIE....eieecee ettt 3
1.2 SOFIWAIE ..o 5
1.3 Program INStallation............cccooiiiieiiiic e 6

2 USEI MANUAL ... 8
2.1  Record new data by NeOFIEX RT ......couiiiiiiiieriieie e 9
2.2 Analyze existing data by NeOFIEX RT .....c.cooviiiiiiiieiece e 11

2.2.1 Open a NeoFlex RT data file and whole data analysis..............cccccoevvervnennenn. 11
2.2.2 Screen out bad BIOCKS ..........ociiiiiiice 13
2.2.3 Signal average and save the output file..........ccccoreiiiiniiiiec 14

0 B O 11 T g8=] 1] T 1SR 17
2.3.1 DAQ DOAId SEL UP .ovveeieiiiiieeie ettt 17
2.3.2 ProtoCOl file.......ooieiiie s 17

3 RETEIBNCES. ...ttt 19



NeoFlex RT CNL U of Kansas

1 NeoFlex RT Setup

NeoFlex RT® (real time) is used to record and on-line or post-process the data for Motor
Pulse, LVDT, Load Cell, Suck Pressure, EMG OOS-R, EMG OOS-L, EMG OOI-R, EMG OOlI-
L, which are recorded from 8 channels of NI DAQ board. The purpose of this software is to
select the best user-defined data blocks (named as signal average.txt) which will be used for

further analysis by other commercial software (for example, Minitab, MATLAB, etc.).

Suck Pressure is the signal used to trigger the impulse in Motor Pulse, thus the baby will
receive a probe tap on the left upper lip from an actuator controlled by its own suck pressure.
The triggering levels in suck pressure are typically set to 5 cmH,0 (30 repetitions) and 10 cmH,0

(30 repetitions) in a protocol file which sets the rules of how the data are recorded.

1.1 Hardware
The Hardware for this testing equipment includes:
- A PC with Windows XP and 1 GB RAM
- NI DAQ 6052E and BNC 2110
—> Coulbourn waveform discriminator/comparator
-> Bridge Amplifier
- AC PreAmplifiers (up to 4-channels)
- DVRT
-> Force servo actuator
(Neuro Logic, LLC & BioCommunication Electronics, LLC)
-> Sensors: pressure sensor and EMG signal sensors

All the hardware listed above is set up according to Figure 1. Baby’s suck pressure and
EMG signals sampled proximal to the SOOTHIE™ silicone pacifier nipple will be input to

NeoFlex and then recorded.
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Figure 1. Hardware setup for NeoFlex RT



1.2 Software
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This software is coded by C# (13,195 coding lines) according to the structure showed in

Figure 2. It performs functions like recording/creating new data, analyzing existing data,

plotting all 8 channels data to users’ preference, changing data acquisition configuration,

selecting data blocks by users, saving averaged signal for user selected data blocks, and etc.

Structure Plot of NeoFlex RT

NeoFlex o—
— —
frmMain.cs]

e

e Tools @—p Protocol EditorlfrmProtocoIEditor.c-sJ

— New [frmNew.cs

{ Data File  frmMain.csOfrmNew.csO btnDataFileBrowse_Click()

_—-— Protocol File frmMain.csOfrmNew.csO btnProtocolFileBrowse_Click()
— Open frmMain.csd mnuFileOpen_Click():Open an existing .dat file
e File — Page Setup frmMain.csdmnuFilePageSetup_Click()
M Print frmMain.csEmnuFilePrint_Click()
— Exit frmMain.vbOmnuFileExit_Click()
~— DAQ lfrmSemngsDAQ.ci’ 8*Al & 2*AO0 calibration settings for DAQ board
=
—e Settings— [ Graph lfrmSettingsGraph.C_s’ Y Axis scale setting for 8*Al plots
T Analysis |frmsemﬂsﬁy5is_-csl Trigger setting for AO
— Protocol l frmProtocal.cs
g _ = — Page Setu
— File—— Print
l— Blocks WindowrfrmBIocksAnalysis.cs1 — Exit Y Axis scale
— s o e’ R — e e Y
e View — Settings @—p Graph r?rmBIoc etti gsGraph.cs] STmng for 8*Al
— Save P
Fil — Page Setup
File—
Signal Average p = = =— Print
— W?ndow 9 rfrmSignaIAverage.cg — Exit
_—- — e —— —— — *Aritfact Window Size

Artifact frmSigAvgSettingsArlifact.csI *Pre-Trigger Demean

Settings e e e == ™ | Y Axis scale setting
SeMtings™ L Graph [ mSigAvegSetingsGraph cs] o g i
Single Graph
—_——
M‘i

—e Help[ frmAbout.cs1
— — —r

Nov 17, 2005 by Joan

Figure 2. Coding structure plot for NeoFlex RT
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1.3 Program Installation

1. Be sure to install the NI-DAQ 6.9.3 driver.

2. Uninstall any previous installed versions of NeoFlex RT using Control Panel >

Add/Remove Programs.
3. Install NeoFlex RT by running setup.exe from the installation package.

Note: Normally, it works with BNC-2090(Figure 3). To work properly with the
BNC-2110 (Figure 4) please make the following change:

Figure 3. BNC-2090
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Figure 4. BNC-2110
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For BNC-2110

To work with BNC-2110, terminal configuration has to be in differential mode. Terminal
configuration can be set to differential mode by modifying the parameter value of
“defaultAiTerminalConfig” to “1” under <systemConstants> section in the file
NeoFlex.exe.config located in C:\Program Files\Neuro Logic\NeoFlex RT\. Here is the line

from NeoFlex.exe.config that shows this parameter value
<add key="defaultAiTerminalConfig" value="1" />
“defaultAiTerminalConfig” can have the following values:
value="1" for Differential
value="2" for Referenced single ended
value="3" for Nonreferenced single ended

By default, the file NeoFlex.exe.config contains value="3" for
“defaultAiTerminalConfig”. This setting is used to work with BNC-2090. Here is the line from

NeoFlex.exe.config that shows this parameter value

<add key="defaultAiTerminalConfig" value="3" />
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2 User manual

When opening the NeoFlex RT, a blank window appears as shown in Figure 5. User

could apply this set of software and hardware to record new data or analysis existing data:
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Figure 5. Blank window for recording
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2.1 Record new data by NeoFlex RT
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User has to input a new file name in order to Record new data. Go to File->New, and

“File New” dialog (Figure 6) will pop up to enable user to input new file name and choose the

desired protocol file. After the data file and protocol file are selected, user could click OK to

start to record.
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Figure 6. “File New” dialog

An active “Start” button and a disabled “Stop” button will appear on the recording

window (Figure 7). User could click Start button to start recording. Meanwhile, the “Stop” will

be enabled; and user could click Stop button to stop.

The protocol window showed in left lower corner window is the current recording

protocol for user’s reference.
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After recording, the user could apply the methodologies introduced in 2.2 to analyze
reflex data in more detail.
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2.2 Analyze existing data by NeoFlex RT

After opening an existing data file (.dat) for NeoFlex analysis, another two windows will
automatically pop up. These include a blocks analysis window for screening out bad blocks, and
a signal average window for saving averaged signal according users’ criterion. In other words,
these two windows perform as the next two steps that lead users to find out the averaged signal

for each channel based on user selected good data blocks.

2.2.1 Open a NeoFlex data file and whole data analysis

To open a NeoFlex data file, just go to File and click Open as typically done in any
Microsoft office software. In the open file dialogue (Figure 8), select the *.dat file which will be
analyzed in NeoFlex RT. Please notice in order to open «.dat file correctly, the «.ph.xml and
«prm.xml file which are generated along with *.dat file in recording data should also be in the

same directory.

Open a
Lock i | £ B j ek ER-
LY = smb3-09-05. dat
7 [ smb3-09-08h.dat
My Recent = t49_101405 reflex.dat
Documen s test‘ dat
—
Desktop
My Documents
<
58
Iy Computer
3
My Network. File name: ‘ j Open
Flaces
Files of lype: |Dats Files [*.dat) =] Cancel

Figure 8. Open file dialog

After opening the data file, the whole data will be showed in NeoFlex RT window similar

to Figure 9.

11
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NeoFlex RT - C:\Program Files\Neuro Logic\NeoFlex RT\Datalt49_101405_reflex. dat
File Settings View Tools Help

HMotar Pulse [] EMG OO

EMG D0OS-L (]

LOaD CELL (M) EMG D0I-R [u)

NeoFlex RT °

Real Time

Date Created: 10/14/2005 11:03:20 &M

Figure 9. NeoFlex RT window for entire data analysis

The scroll bar in right lower corner enables user to look the data for 8 channels from

beginning to end, therefore user could identify if the whole recorded data are satisfied or not.

In menu Setting—>Graph, user could define the upper and lower data display limit of
each graph to accommodate individual user preference. Or user could simply check “Auto

Scale” box to make all graphs automatically scaled. (Figure 10)
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Figure 10. Graph setting window

2.2.2 Screen out bad blocks
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In this Blocks Analysis window (Figure 11), the whole data set shown in the last window

(Signal Average).

13

(NeoFlex window) is divided into small windows with 150ms length for each window. User
could press “Previous”, “Next”, “First” and “Last” buttons to view the whole data set. When
encountering a bad data block that is not desired in final signal average analysis, user could

check “Tag as bad block” to remove it from signal averaging that will show in the third window
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Figure 11. Block analysis window

2.2.3 Signal average and save the output file

After screening out all the bad blocks, the average signal showed in this window (Figure
12) is calculated based on the entire user defined good data in window “Blocks Analysis”. Then
user could save the averaged data as .txt file by go to File->Save.

User could also select to see and save different average signal based on different
calculation method. This function is enabled by user at selection box in the lower right corner of

this window. Six different signal averaging methods are listed below:

1. 5 off: The trigger level in suck pressure is set to 5 cmH,0. The average signal
calculated by this method doesn’t include the blocks with Motor Impulse

triggered. In other words, the blocks contributed to this average signal represent

14
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an experimental control condition in which the EMG profiles associated with suck

are sampled without a perturbating stimulus.

.5 on: The trigger level in suck pressure is set to 5 cmH,0. The average signal

calculated by this method just includes the blocks with Motor Impulse triggered.

.10 off: The trigger level in suck pressure is set to 10 cmH;0. The average signal
calculated by this method doesn’t include the blocks with Motor Impulse
triggered. In other words, the blocks contributed to this average signal represent
an experimental control condition in which the EMG profiles associated with suck

are sampled without a perturbating stimulus.

.10 on: The trigger level in suck pressure is set to 10 cmH,0. The average signal

calculated by this method just includes the blocks with Motor Impulse triggered.

. 5 on-off: The average signal showed by this method is calculated by the signal
from second method (5 on) minus signal from first method (5 off). It displays
the net response of EMG signal after the baby’s lip is tapped by the probe.

. 10 on-off: The average signal shown by this method is calculated by the signal
from fourth method (10 on) minus signal from third method (10 off). It displays
the net response of EMG signal after the baby’s lip is tapped by the probe.

15
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= Signal Average - C:\Program Files\Neuro LogiciNeoFlex RT\Data\t49_101405_reflex. dat
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Figure 12. Signal average window

The other function to assist user to look through the average signal in more details is the blue and
red cursor. User could drag (or move them by up-down and right-left keys on keyboard) the blue
and red vertical lines in any graph, and the cursor table in left lower corner will show the exact

cursor position and the distance between two cursors in which user are interested.
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2.3 Other settings

The settings in this part shouldn’t be changed once they are set at the beginning of data

recording.

2.3.1 DAQ board set up

From the main NeoFlex window, data acquisition criterion could be set in
Setting=>DAQ as shown in Figure 13. User could define the minimum and maximum value,
calibration rate, and channel name for all 8 input channels and 2 output channels. User could
also read and change the sampling rate for input and output channels to accommodate individual

user applications.

DA Device:
A an |
Sample Rate: [Gaog  samplesis
Down Sample [lio samples
Buifer Size [F samples
Chaningls
Motor Pulse VDT Load Cell Suck Pressure
AlChamet  [achn ] 4| Charrel e =] A Charrel [aciz =] A Channel [ac: =]
Physical Unit ’1— W Physical Urit ’5— mm Physical Unit ’DE— N Physical Unit: ]m— cm H20
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Figure 13. DAQ setting window

2.3.2 Protocol file

In NeoFlex window, click Tools=>Protocol Editor to activate protocol editor window as

shown in Figure 14. In this window, user could change data recording protocols. For example,

17
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our default protocols are: The trigger level set in suck pressure is 5 cmH,0, which will be
repeated 30 times. After that, the trigger level will automatically rise to 10 cmH-0, and the
experiment will be repeated for another 30 times under this trigger level. User could define new

protocol in this window to change the trigger level and repetition time.

58 protocol File Editor - Untitled (=113

Add Maodify Delete

Figure 14. Protocol Editor dialog

All the protocols will be saved in Protocol file (=.pf), which is an XML file that contains
test protocol - a sequence of test conditions with repetition count for running the experiment. A
protocol file can be created or modified using the Protocol Editor as we detailed earlier. User

selects the protocol file to be used for the experiment during a File New operation.

With correct NeoFlex RT installation, user can locate the protocol file under directory:

C:\Program Files\Neuro Logic\NeoFlex RT\Protocol. Here is a sample file:

<?xml version="1.0" standalone="'yes"?>
<ProtocolDataSet>
<Protocol>
<SuckPr>5</SuckPr>
<Repetition>30</Repetition>
</Protocol>
<Protocol>
<SuckPr>10</SuckPr>
<Repetition>30</Repetition>
</Protocol>
<Protocol>
<SuckPr>15</SuckPr>
<Repetition>30</Repetition>
</Protocol>

</ProtocolDataSet>
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